PDA

View Full Version : Help ! Cherry dies...



Sweet Angel
4th May 2006, 11:09 AM
My tank infested by hair algae so recently I added DIY CO2, from 1 bottle now I have 3 bottles of DIY CO2 bubbling in different areas of the tank.
Before I add the CO2, I've seen dead cherries & I suspected it was because fish attack. Now I've removed that fish suspect, only 1 guppy left & I believe it's a peaceful fish, won't attack shrimps.
But later days I saw dead cherries again, is it because the CO2 adding..? The guppy seems gasping a bit, but still ok. It's been almost a week now after I added CO2.

One more question, do CRS eat more varies algae than cherries? Or do CRS eat more than cherries?
I have nano tank in office, fill with CRS & cherries, CRS don't breed (water condition suspected) but till now still survive & healthy, cherries breed like crazy at first, but now all the adults are gone, leaving only the little & medium ones...
I suspect cherries adult can't compete when looking for food...? :undecided

babypiggy
4th May 2006, 01:20 PM
I think it is best to check your water parameters e.g. ammonia,phosphate,nitrate and nitrite.

Cherry shrimps are more hardy than CRS.
You can try placing the same amount of food, but in smaller peices everywhere in the tank.

Robert
5th May 2006, 06:53 AM
Hi,
did you ever check your KH (carbonate hardness) and the pH to calculate the CO2? It seems as if you add too much CO2 at the moment. The gasping guppy is a clear sign. The pH will swing and shrimps suffer from such swings. It could even be the cause of thier deaths. Add less CO2 and messure the mentioned parameters.

regards
Robert

Sweet Angel
5th May 2006, 10:02 PM
Thanks for the reply...

I add more CO2 cause I try to kill hair algae that invested almost all part of my tank >(
I know it's safer if I move all the shrimps, but it's not easy to catch the shrimps one by one from the heavily planted tank :cry:

I bought expensive JBL test strips to check all necessary parameters from the beginning, & all water parameter were okay. But since I add more CO2 I didn't check again...

babypiggy
5th May 2006, 10:33 PM
Are the test strips the all in one type?
I heard that they are not that accurate, not sure why.
You should try testing again.Try to remove hair algea by hand maybe that will help.